Created اتوار 10 اگست 2014

Error: Unable to correct problems, you have held broken packages. |  How to fix broken packages? |  resolve unmet dependencies?

It is always a good idea to back up configuration files like /etc/apt/sources.list, so you can revert the changes if needed.

Step-1: Make sure that the restricted and universe repositories are enabled. Hit Alt+F2, type software-properties-gtk and hit Enter.

Softwares

 

 

 

 

 

 

 

 

Step-2: Clean up any partial packages.
sudo apt-get clean
or
sudo apt-get autoclean

Step3: Clean up the apt cache.
sudo apt-get autoremove

Step-4: One of the most basic fixes to resolve dependencies problems is to run:
sudo apt-get -f install

Step-5: Update your package list.
sudo apt-get update

Clean up any unneeded dependencies: sudo dpkg --remove -force --force-remove-reinstreq package name

 

Recommended For You.

Red Hat Enterprise Linux 7 / CentOS 7 rpm -ivh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm yum update Red Hat Enterprise Linux 6 / CentOS 6 rpm -ivh https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm yum